Category: Switches

Allerlei zaken m.b.t. configuratie van managed switches.

Hoe Factory Reset je een HP Procurve 2510-24G Switch ?

Hoe Factory Reset je een HP Procurve 2510-24G Switch ?

Factory Reset van een Procurve 2510

Je hebt een leuke HP Procurve 2510 Managed switch op de kop getikt en vol enthousiasme wil je gaan vlans er op gaan zetten, trunks maken, QOS gaan instellen.
En dan gebeurd het : De verkoper heeft nagelaten om de switch te resetten zodat jou nu gevraagd wordt een wachtwoord in te vullen als je via de console werkt, of als je geen console kabel hebt, met de vraag zit welk IP adres de switch in hemelsnaam heeft.

De verkoper is niet (meer) bereikbaar en je kunt niet verder….of toch wel ?

Factory Reset uitvoeren

Het enige dat je wil is een standaard, lege config. Dat kan door de switch te resetten naar fabrieksinstellingen.
Daar zit een truukje aan en het komt allemaal neer op het juiste moment indrukken en loslaten van de knopjes en het is geregeld.
Lees daarom deze instructie éérst voordat je begint en het keer op keer niet lukt.

Aan de slag !

Aan de linkervoorzijde zien we een soort bedieningspaneel met statusmeldingen en knopjes.

procurve 2510 factory reset 01

Om te resetten naar Factory defaults moet de switch eerst aan staan en opgestart zijn.
Dus de stroom er op en even wachten tot de switch gestart is.

Vervolgens kun je gaan resetten. Hier voor kun je beste 2 paperclips gebruiken.
Steek de 2 paperclips in de gaatjes bij Reset en Clear :

procurve 2510 factory reset 03

Vervolgens zie je dat alle lampjes beginnen te branden :

procurve 2510 factory reset 02

Als alle lampjes branden laat je de knop Reset los.
Kort daarna zal het Test lampje gaan knipperen :

procurve 2510 factory reset 04

Op dat moment laat je de knop Clear ook los.

De switch zal daarna zichzelf gaan resetten. Alle instellingen zullen verloren gaan.
Als de switch weer opgestart is en alle lampjes in ruststand staan, heb je een lege, bruikbare switch en kun je deze gaan configureren.

Wanneer het niet lukt, heb je knopjes op het verkeerde moment ingedrukt of losgelaten. Start de switch dan opnieuw op en probeer het nog een keer.
Het moment van indrukken/loslaten is heel belangrijk !

Cheers !

NIC Teaming opzetten in Windows Server 2012

NIC Teaming opzetten in Windows Server 2012

Server 2012 NIC Teaming

NIC Teaming oftewel het samenvoegen van meerdere netwerkkaarten voor meer snelheid en failover mogelijkheden !
Voor Server 2012 moest het teamen van NIC’s gebeuren met software van de fabrikanten. Server 2012 ondersteund out-of-the-box al Teaming !

Wat is Teaming ?

Zoals gezegd is het teamen van netwerkkaarten niets anders als het samenvoegen en stapelen van netwerkkaarten.
Wat het nut er van is ?
Nou, dat is best heel erg nuttig omdat wanneer je 4x een 1Gb netwerkkaart hebt, deze kunt samenvoegen tot 1 netwerkkaart die een snelheid kan halen van 4 Gbit !
Deze netwerkkaart verbindt je uiteraard met 4 netwerkkabels aan je switch.
Deze 4Gbit netwerkkaart kun je vervolgens een IP adres geven en eventueel meerdere virtuele NICS maken voor verschillende vLAN’s !
Het voordeel is dat je hogere doorvoersnelheden kunt halen, maar ook failover hebt. Als 1 of 2 netwerkkaarten of kabels kapot gaan, werkt het altijd nog hetzij op een wat lagere snelheid.
Maak je je team switch onafhankelijk ? Dan kun je je team bijvoorbeeld over 4 switches verdelen om een failover te maken.

Hoe maken we een TEAM in Server 2012 ?

Hiervoor hebben we minimaal 2 netwerkkaarten nodig, in dit voorbeeld gebruiken we 2x 1 Gbit netwerkkaart.

In Server 2012 ga je naar de Server Manager, klik daar op Local Server en aan de rechterkant zie je dan NIC Teaming staan.
Klik daar op Disabled om Teaming op te zetten.

Server 2012 NIC Teaming setup 01

Nu komen we in onderstaand scherm.
Klik in de kolom bij TEAMS op de knop Tasks en kies New Team

Server 2012 NIC Teaming setup 02

Dan krijg je onderstaand scherm.
Geef de Team een naam en selecteer de netwerkkaarten die opgenomen moeten worden in de team.
De additional properties zijn afhankelijk van jouw situatie.

Server 2012 NIC Teaming setup 03

Als je op OK hebt geklikt, wordt de Team opgeslagen. Dit kan even duren…

Server 2012 NIC Teaming setup 04

Dan kom je terug in onderstaand scherm.
Je ziet nu bij TEAMS dat je een team hebt en aan de rechterkant bij Adapters and Interfaces zie je welke netwerkkaarten er zijn.

Server 2012 NIC Teaming setup 05

Nu klik je bij Adapters and Interfaces op Team Interfaces
Je ziet dan ook hier de team die je net gemaakt hebt.

Server 2012 NIC Teaming setup 06

Als je nog een vLAN tagged Interface wilt toevoegen, klik dan op Tasks en dan Add Interface
Om vLAN’s te gebruiken moet je uiteraard weten wat dit is en hoe je dit in moet richten !
Heb je dit nog nooit gedaan ? Ga hier dan eerst mee testen in een testomgeving, NOOIT in een productie omgeving omdat je je complete netwerk onbereikbaar kunt maken met alle gevolgen van dien !
Lees dit artikel voor een vLAN introductie.

Server 2012 NIC Teaming setup 07

Geef een naam aan je nieuwe Team en geef een vlan nummer op waarmee deze team verbinding mee moet hebben.
Druk vervolgens op OK om de nieuwe team aan te maken en op te slaan.

Server 2012 NIC Teaming setup 08

Indien we nu de status van de team bekijken, zien we dat we een netwerkkaart (team) hebben met een snelheid van 2 Gbps !

Server 2012 NIC Teaming setup 09

Deze nieuwe netwerkkaart kun je inrichten zoals een gewone netwerkkaart.
Je kunt deze dus gewoon een IP adres geven, default gateway, DNS etc.
De Teaming configuratie zorgt er dan voor dat de configuratie op de afzonderlijke netwerkkaarten terecht komt.

Conclusie

Wat je nu hebt gecreëerd is een netwerkkaart die switch onafhankelijk werkt.
Als je deze 2 netwerkaarten met 2 netwerkkabels op 2 switches aansluit, zal dit gewoon werken als een 2Gbps netwerkverbinding.
Je hebt dan een failover voor het geval 1 switch, netwerkkabel of netwerkkaart kapot gaat !
Wanneer er een onderbreking in de team zit, zoals een kapote kabel, nic of switch, zal de team een failover genereren en al het verkeer over de nog werkende verbinding sturen.
Ook de doorvoersnelheid zal dan omlaag gaan naar 1 Gbps uiteraard.

Dit is een prima oplossing om een High Availability oplossing te maken voor servers !

 

HPE 5920 IRF Stack bouwen met 4 switches

HPE 5920 IRF Stack bouwen met 4 switches

IRF Stack met 4 HPE 5920 Switches

IRF (Intelligent Resilient Framework), is een innovatie van H3C en HPE heeft deze techniek bemachtigd en daarmee hun 59xx switches uitgerust.
Met de IRF techniek kun je van meerdere switches 1 virtuele switch bouwen, dus je hebt 1 management IP adres en je zorgt voor een hoge mate van High Availability. De switches worden onderling verbonden d.m.v. IRF poorten welke je naar eigen wens kunt inrichten. Failover mechanismen zoals bijvoorbeeld Vrrp heb je hiermee niet meer nodig.

We gaan in dit artikel een IRF Stack bouwen met 4 switches, er van uitgaande dat de switches nog geen configuratie bevatten, bevat je 5920 al wél een bestaande configuratie ? Maak hier dan eerst een backup van !

Wat wordt het eindresultaat ?

  • Een werkende IRF Stack met 4 members
  • FAN Direction voorkeur is ingesteld
  • Het systeem heeft een naam

Hoe gaat het er uit zien ?

Onderstaand plaatje geeft aan hoe de switches met elkaar verbonden gaan worden en worden Slots genoemd :

IRF-5920

De configuratie van de switches

Er van uit gaande dat je de switches net uit de doos hebt gehaald en dus nog geen configuratie bevatten (de switches verliezen namelijk hun configuratie nadat je IRF hebt ingericht) gaan we dus met een lege config aan de slag.

De truc is om niet met de eerste switch te beginnen. De IRF Stack wordt dan namelijk niet actief.
Begin dus met de tweede switch, daarna de eerste, dan de derde en tot slot de vierde.

IRF Members maken

Als eerste dienen we de IRF members (fysieke switches zijn members) te nummeren en te prioriseren, switch 1 is reeds member 1, we beginnen met de tweede switch :

Switch 2

system-view

irf member 1 renumber 2

save force

quit

reboot

y (yes om te rebooten)

Switch 3

system-view

irf member 1 renumber 3

save force

quit

reboot

y (yes om te rebooten)

Switch 4

system-view

irf member 1 renumber 4

save force

quit

reboot

y (yes om te rebooten)

Na het rebooten kunnen we de IRF status controleren, we nemen even member 2 ter illustratie :

[HP]display irf
MemberID Role Priority CPU-Mac Description
*+2 Master 1 5c8a-38b0-bbcd —
————————————————–
* indicates the device is the master.
+ indicates the device through which the user logs in.

The Bridge MAC of the IRF is: 5c8a-38b0-bbcc
Auto upgrade : yes
Mac persistent : 6 min
Domain ID : 2

Hierboven zien we dat de MemberID op 2 staat, dus dit klopt.
Bij member 1, 3 en 4 zal dit ook goed moeten staan alvorens we verder kunnen.

IRF Poorten toewijzen

We beginnen zoals gezegd met Member 2 :

Er moeten 2 IRF poorten geconfigureerd worden, maar om dit te bereiken moeten deze eerst uitgeschakeld worden.
Volgorde voor elke switch :
– Poorten uitschakelen
– IRF Poorten maken
– Poorten activeren
– Configuratie opslaan
– IRF activeren

Switch 2

system-view

interface range Ten-GigabitEthernet 2/0/21 to Ten-GigabitEthernet 2/0/24

shutdown

irf-port 2/1

port group interface Ten-GigabitEthernet 2/0/21

port group interface Ten-GigabitEthernet 2/0/22

quit

irf-port 2/2

port group interface Ten-GigabitEthernet 2/0/23

port group interface Ten-GigabitEthernet 2/0/24

quit

interface range Ten-GigabitEthernet 2/0/21 to Ten-GigabitEthernet 2/0/24

undo shutdown

save force

irf-port-configuration active

Switch 1

system-view

interface range Ten-GigabitEthernet 1/0/21 to Ten-GigabitEthernet 1/0/24

shutdown

irf-port 1/1

port group interface Ten-GigabitEthernet 1/0/21

port group interface Ten-GigabitEthernet 1/0/22

quit

irf-port 1/2

port group interface Ten-GigabitEthernet 1/0/23

port group interface Ten-GigabitEthernet 1/0/24

quit

interface range Ten-GigabitEthernet 1/0/21 to Ten-GigabitEthernet 1/0/24

undo shutdown

save force

irf-port-configuration active

Als alles goed gaat, zal member 2 nu gaan rebooten, we kunnen verder met member 3 en 4

Switch 3

system-view

interface range Ten-GigabitEthernet 3/0/21 to Ten-GigabitEthernet 3/0/24

shutdown

irf-port 3/1

port group interface Ten-GigabitEthernet 3/0/21

port group interface Ten-GigabitEthernet 3/0/22

quit

irf-port 3/2

port group interface Ten-GigabitEthernet 3/0/23

port group interface Ten-GigabitEthernet 3/0/24

quit

interface range Ten-GigabitEthernet 3/0/21 to Ten-GigabitEthernet 3/0/24

undo shutdown

save force

irf-port-configuration active

Member 3 zal nu ook gaan rebooten, verder met member 4, de laatste !

Switch 4

system-view

interface range Ten-GigabitEthernet 4/0/21 to Ten-GigabitEthernet 4/0/24

shutdown

irf-port 4/1

port group interface Ten-GigabitEthernet 4/0/21

port group interface Ten-GigabitEthernet 4/0/22

quit

irf-port 4/2

port group interface Ten-GigabitEthernet 4/0/23

port group interface Ten-GigabitEthernet 4/0/24

quit

interface range Ten-GigabitEthernet 4/0/21 to Ten-GigabitEthernet 4/0/24

undo shutdown

save force

irf-port-configuration active

En je raadt het al, member 4 zal ook gaan rebooten 🙂

Mocht de IRF config niet opkomen, controleer dan de aansluitingen van de IRF poorten, deze moeten namelijk op volgorde aan worden gesloten zoals de afbeelding hierboven laat zien :
irf1/1 –> irf 2/2
irf2/1 –> irf 3/2
irf3/1 –> irf 4/2
irf4/1 –> irf 1/2

Als alle members weer actief zijn heb je als het goed is 1 grote virtuele switch bestaande uit 4 slots/members
De poorten van member 1 zijn genaamd 1/0/xx
De poorten van member 2 zijn genaamd 2/0/xx
De poorten van member 3 zijn genaamd 3/0/xx
De poorten van member 4 zijn genaamd 4/0/xx

Member priority instellen

Wanneer de IRF configuratie klaar is, is het belangrijk om te weten dat vanaf nu alle configuratie wijzigingen op member 1 plaats moeten vinden aangezien anders de config gewist zal worden !

We kunnen nu de priority instellen van de verschillende members op een waarde tussen 1 en 32 waarbij 32 de hoogste prioriteit is :

Connect met member 1 :

system-view

irf member 1 priority 32

irf member 2 priority 31

irf member 3 priority 30

irf member 4 priority 29

save force

Dat is alles !

Fan preferred direction instellen

Mogelijk brandt er een rood systemlampje welke eigenlijk groen moet branden. Dit ligt waarschijnlijk aan de configuratie van de fans in de switch.
Als dit door de fans komt, zul je meldingen op de console voorbij zien komen over fans in slot 1,2,3,4.

Dit is eenvoudig op te lossen !

Connect met member 1 :

Port-to-power of Power-to-port is afhankelijk van welke Fan module je in de switch hebt zitten !

fan prefer-direction slot 1 port-to-power
fan prefer-direction slot 2 port-to-power

fan prefer-direction slot 3 port-to-power
fan prefer-direction slot 4 port-to-power

save force

Je IRF Stack een systeem naam geven

Mocht je nog de systeem naam aan willen passen, dan kan dat ook eenvoudig :

system-view

sysname KIESEENNAAM

save force

Controle van de IRF configuratie

We kunnen met wat commando’s controleren of de IRF verbinding goed tot stand is gekomen :

Het commando display irf

dis irf

hpe 5920 irf 1

In bovenstaand overzicht zien we dat alle 4 members aanwezig zijn. Member 4 is de master (te zien aan het *) en op Member 1 zijn we ingelogged (te zien aan de +)

Het commando display device

dis device

hpe 5920 irf 2

Hier zien we een overzicht van de aanwezige switches, alle 4 staan ze er in.

Het commando display irf topology

dis irf topology

hpe 5920 irf 3

Nu krijgen we een overzicht te zien met de aanwezige links van en naar members.
Hier kun je dus zien welke IRF poort met welke Member verbonden is.

Het commando display lldp neighbour-information list

dis lldp neighbour-information list

hpe 5920 irf 4

Een overzicht van de door LLDP gedetecteerde neighbours en op welke poorten zich deze bevinden.

Ziet er allemaal goed uit dus !

Klaar !

Je hebt nu een werkende IRF Stack, of in ieder geval de basis om verder te configureren !
Nu kun je verder met vLAN’s, routing, port switching, toekennen van IP adressen etc en de stack dus helemaal naar eigen wens inrichten.

Dit artikel is gemaakt aan de hand van een IRF config die ik gemaakt heb op 4 HPE 5920AF-24XG switches waarbij 2 op Site A komen en onderling met 2 DAC kabels verbonden zijn en vanuit elke switch 2x 10Gbit glasvezel naar 2 switches op Site B welke onderling ook weer met 2 DAC kabels zijn verbonden.
De switches zullen als een 10Gbit backbone ingezet worden voor een VMware 6.5 Enterprise Plus cluster en een iSCSI cluster met 6 StoreVirtual nodes en 2 3PAR nodes wat als geheel vreselijk zal gaan vlammen ! 🙂

HPE 5920AF-24XG IRF
Wees er zeker van dat je een cirkel maakt om bij een defecte kabel een split-brain te voorkomen. In een cirkel kun je bij een kabel breuk altijd bij je bestemming komen.

De switches zullen komende tijd nog verder ingericht worden en bij leuke en/of interessante features zal ik dit artikel aanvullen.

Succes !

 

Introductie tot vLAN’s

Introductie tot vLAN’s

Wat in de wereld van networking ook zeer interessant is en mooi om in de praktijk te brengen is, zijn vLAN’s

Maar wat is een vLAN eigenlijk ?
Een vLAN is simpel gezegd een Virtual LAN.
Je kunt als je verschillende subnets wilt implementeren voor verschillende toepassingen of apparaten er voor kiezen om fysieke switches te gaan gebruiken.
Dat werkt prima, maar als je 20 subnets hebt, wordt het er niet praktischer op om 20 switches te gaan inzetten.
Voor de kosten hoef je het niet te doen evenals het beheren ervan.
vLAN’s gebruiken is effectief, flexibel en makkelijk te implementeren.

Om gebruik te kunnen maken van vLAN’s heb je een managed Switch nodig. Een switch die je dus kunt beheren.
Het is het noodzakelijk dat je een Layer 2 Switch hebt aangezien vLAN’s op layer 2 (Data link layer) van het OSI model opereren :

osi-model

Een vLAN is niks anders als een virtuele switch. Op een managed switch is het mogelijk om in 1 fysieke switch meerdere virtuele switches te configureren en daar poorten aan toe te wijzen.
We gaan nu niet héél erg diep op het vLAN gebeuren in, maar we pakken even een paar praktische voorbeelden erbij wat we met vLAN’s kunnen bereiken.

Doelstelling :

vlan

Hierboven zien we Switch A en Switch B
Elke switch heeft 3 vLAN’s 1,2 en 3
Switches A en B zijn met elkaar verbonden met een Trunk. Een trunk is het transport van vLAN’s tussen verschillende switches.
in een vLAN kennen we Tagged en Untagged poorten.
een tag is niets anders als een label aan netwerkverkeer zodat duidelijk is bij welk vLAN dit verkeer hoort.
Een trunk zal dus altijd Tagged zijn verkeer afleveren anders weet de ontvangende switch natuurlijk niet bij welk vLAN dit hoort.
Alle 3 VLAN’s zijn gescheiden, dus apparaten in vLAN_1 kunnen niet “kijken” in VLAN_2 of VLAN_3

Het voordeel in dit voorbeeld is dat we met 2 switches die we bijvoorbeeld op 2 sites hebben geplaatst, 3 subnets kunnen afleveren, maar dat kunnen er net zo goed 30 zijn.

TRUNKS :
Tagged vs. Untagged :

Een trunk zal dus altijd zijn verkeer tagged afleveren en ontvangen om de pakketjes in het juiste vLAN terecht te laten komen.
Untagged poorten zijn in de meeste gevallen bedoeld voor de endpoints zoals computers, laptops, printers etc.
Soms kun je een endpoint ook Tagged aansluiten zoals bijvoorbeeld een WiFi Access Point die meerdere SSID’s uit laat komen op meerdere vLAN’s

In de praktijk :
Laten we eens een config voorbeeldje pakken :

We loggen in op een HP 24 poorts Procurve managed switch waarbij poort 23 en 24 als trunk wordt ingericht naar Switch B
Poort 1-10 is voor vlan_1
Poort 11-20 is voor vlan_2
Poort 21-22 is voor vlan_3

Om de switch te configgen gebruiken we het commando conf t gevolgd door enter
Vervolgens de volgende commando’s (elke regel gevolgd door enter):

trunk Trk1 23-24 trunk
vlan 1
tagged Trk1
untagged 1-10
vlan 2
tagged Trk1
untagged 11-20
vlan 3
tagged Trk1
untagged 21-22
wr mem

Bovenstaande config kun je op Switch B ook laden aangezien we voor dit voorbeeld voor gelijke configs gaan.
Nu kun je een netwerkkabel in poort 24 van beide switches steken om de trunk te activeren.
In Switch A kun je een computer in poort 1-10 (VLAN_1) prikken en op Switch B ook en ze zullen met elkaar kunnen communiceren.
Prik je de computer in Switch A op poort 11-20 (VLAN_2), dan zul je merken dat ze niet meer kunnen communiceren ; ze bevinden zich in verschillende netwerken.
Wanneer je de computer op Switch B in poort 11-20 prikt, zitten de computers weer in hetzelfde vLAN en is communicatie weer mogelijk.

Een tip :
Wanneer je twijfelt of een configuratie wel of niet gaat werken op een switch, kun je eerst de config uitwerken in notepad en dan kopieer en plak je de config in de CLI van de switch.
Gebruik het commando wr mem dan nog niet ! dit zorgt er namelijk voor dat de config wordt vastgelegd.
Wanneer je je zelf buitensluit van de switch kom je er namelijk niet meer gemakkelijk bij wat vaak tot het resetten van de switch leidt.
Mocht het gebeuren dat na het configgen de switch onbereikbaar wordt, haal je gewoon de spanning van de switch en dan weer opnieuw opstarten.
Alle niet opgeslagen wijzigingen zijn dan weg en de switch start weer op met de laatst opgeslagen configuratie.

Routering inrichten op de switch :
We gaan een stapje verder….
Wanneer je een layer 3 switch hebt, kun je verkeer ook gaan routeren waardoor je dus een switch als router in kunt zetten.
Indien je gebruik maakt van meerdere vLAN’s kun je de switch als router gaan gebruiken om daarmee je Firewall/Internet router te ontlasten.

Voor het gemak pakken we voorgaande config er even bij en passen deze aan door de rode commando’s toe te voegen :
Om de configuratie overzichtelijk te houden, kunnen we vLAN’s ook namen geven, deze zijn in het groen weergegeven
Let op : We gebruiken 10.0.0.254 als onze internet router, dat wordt dus de default gateway voor de switch waar het niet routeerbare verkeer naar toe gestuurd wordt

Switch A :

ip routing
ip route 0.0.0.0 0.0.0.0 10.0.0.254
trunk Trk1 23-24 trunk

vlan 1
name “SERVER VLAN”

ip address 10.0.0.1 255.255.255.0
tagged Trk1
untagged 1-10
vlan 2
name “WERKSTATION VLAN”

ip address 10.1.0.1 255.255.255.0
tagged Trk1
untagged 11-20
vlan 3
name “GASTEN VLAN”

ip address 10.2.0.1 255.255.255.0
tagged Trk1
untagged 21-22
wr mem

Switch B kunnen we ongewijzigd laten tenzij we gebruik willen maken van failover en VRRP mits de switch dit ondersteund.
Op de clients is het nu van belang dat daar de default gateway nu naar het ip adres van Switch wijst en dat is weer afhankelijk van in welk vLAN je zit met de client.
Nu is het ook mogelijk om tussen de verschillende vLAN’s te communiceren.
Wanneer Switch A verkeer ontvangt wat niet routeerbaar is naar 1 van de vLAN’s, dan gooit de switch dat op zijn default gateway naar 10.0.0.254 zodat deze dit verkeer kan afhandelen.

Nog een stapje verder :
Wanneer je met meerdere vLAN’s werkt, heb je zeer waarschijnlijk ook een DHCP Server draaien in je netwerk.
Als we er in dit voorbeeld vanuit gaan dat in VLAN 1 o.a. je DHCP Server draait, zal een device in VLAN 2 en 3 bij het broadcasten naar een DHCP server geen antwoord ontvangen en dus ook geen ip adres krijgen.
Dit kunnen we oplossen middels het volgende :
Er van uitgaande dat je DHCP Server op 10.0.0.200 draait :
1) Maak op je DHCP Server verschillende scopes aan voor de vLAN’s, dus een scope voor het netwerk 10.0.0.0/24, 10.1.0.0/24 en 10.2.0.0/24
2) Log weer in op de switch en zet deze met conf t in configuratie modus.
3) Voeg bij elk gedefinieerd vLAN een ip helper-address toe. Dit Helper address zorgt ervoor dat DHCP broadcasts worden doorgestuurd naar het opgegeven adres.

Praktisch voorbeeld :

ip routing
ip route 0.0.0.0 0.0.0.0 10.0.0.254
trunk Trk1 23-24 trunk

vlan 1
name “SERVER VLAN”

ip address 10.0.0.1 255.255.255.0
tagged Trk1
untagged 1-10
vlan 2
ip helper-address 10.0.0.200
name “WERKSTATION VLAN”

ip address 10.1.0.1 255.255.255.0
tagged Trk1
untagged 11-20
vlan 3
ip helper address 10.0.0.200
name “GASTEN VLAN”

ip address 10.2.0.1 255.255.255.0
tagged Trk1
untagged 21-22

En tot slot : wr mem

Met deze configuratie kunnen devices in vLAN 2 en 3 dus een IP Adres ophalen van de DHCP Server in vLAN 1

Je kunt vLAN’s ook “omgekeerd” gebruiken wanneer je bijvoorbeeld verschillende vestigingen hebt en middels een Dark Fiber (eigen, dedicated glasvezel verbinding) gekoppeld zijn.
Hier krijg je namelijk ook vLAN’s toegekend.
Zorg er voor dat je een mini GBic module (glasvezel module) in je switch hebt zitten. Maak daar een trunk van en maak vLAN’s aan die je toegewezen hebt gekregen van je Dark Fiber leverancier.
De Trunk laat je tagged uitkomen in alle vLAN’s en voila !

Tot zover de introductie tot vLAN’s !

Mocht je vragen hebben hierover, laat het even weten ! Misschien kan ik je helpen 🙂

VrrP inrichten op een HP Procurve

VrrP inrichten op een HP Procurve

Voor het inrichten van een failover naar een backup switch kun je het volgende gebruiken :

“Hoofd” Switch :

Switch natuurlijk eerst in config mode zetten d.m.v. conf t

Eerst VrrP activeren :

router vrrp
virtual-ip-ping
ipv4 enable
exit

Daarna kun je per vLAN VrrP aanzetten :

vlan 2000
name “VLAN_TEST”
untagged 1-12
ip address 10.0.0.1 255.255.255.0
vrrp vrid 1
virtual-ip-address 10.0.0.1
priority 255
enable
exit
exit

Geef het vLAN een fysiek IP-Adres en ken hier een virtual ip address aan toe
vrrp vrid is het virtuele router id, ik gebruik zelf voor elk vlan een nieuw ID.
Priority 255 is de hoogste prioriteit. Wanneer je meerdere switches hebt, kun je de prio’s inrichten en daarmee aangeven welke switch de hoofdswitch wordt na uitvallen van de master.

“Failover” Switch :

Ook hier eerst de switch in config mode zetten en zoals hierboven vrrp activeren.

Daarna het vLAN inrichten :

vlan 2000
name “VLAN_TEST”
untagged 1-12
ip address 10.0.0.2 255.255.255.0
vrrp vrid 1
virtual-ip-address 10.0.0.1
enable
exit
exit

Bijna hetzelfde dus, alleen het fysieke IP adres is natuurlijk anders.

Als alles goed gaat, kun je met “sh vrrp” de status bekijken :

VRRP Virtual Router Statistics Information

Vlan ID : 2000
Virtual Router ID : 1
Protocol Version : 2
State : Backup
Up Time : 20 days
Virtual MAC Address : 00005e-000108
Master’s IP Address : 10.0.0.1
Associated IP Addr Count : 1 Near Failovers : 0
Advertise Pkts Rx : 1797107 Become Master : 1
Zero Priority Rx : 0 Zero Priority Tx : 0
Bad Length Pkts : 0 Bad Type Pkts : 0
Mismatched Interval Pkts : 0 Mismatched Addr List Pkts : 0
Mismatched IP TTL Pkts : 0 Mismatched Auth Type Pkts : 0

Gefeliciteerd ! Je hebt nu een failover gemaakt.